Forum

  • By Howard - edited: January 9

    Just a quick note to relate a problem I recently encountered, that might interest others.

    Hardware Configuration:  Arris cable Modem connected to a Netgear /ac router, using a gigabit Ethernet link.

    About six months ago I was experimenting with the Netgear router, and enabled both its Downlink and Uplink QoS High Performance options.   The performance did increase slightly, but nothing special.    Since there seemed to be no  problems, I left them enabled and proceeded to forget about having changed them.

    Then about two months ago, problems slowly started showing up.    First a gaming PC attached directly through a Cat-6 cable to the Router started dropping in speed, from over 200 Mbps, to 100 Mbps, then to less than 10 Mbps.   A wireless PC at the other end of the house, dropped from 17+ Mbps to an erratic 3 Mbps.  Finally, the Up-link speeds on both PC's, which had been rock- solid at over 10 Mbps, dropped to less than 0.4.   Netflix was also taking a very long time to start up

    I tried all the simple things, like checking cables, VPN enabled and disabled, rebooting everything, but nothing helped.

    Finally, after removing the router from the setup, and connecting the gaming system system directly to the cable modem, it's performance was back to over 200 Mbps.   Then, returning the cables to the original connections, caused the entire network to crawl again.   Obviously the router was the weak link.

    On a hunch, I disabled both the Up-link and Down-link QoS options in the Netgear router, and rebooted everything.

    Voila.    All the problems were fixed.

    Apparently, the QoS settings at my ISP had changed from their original values, and were no longer compatible with the Netgear router QoS parameters.  Note that downloading the latest Router F/W also had no effect. 

    Disabling QoS was the solution to my problems.

    Sometimes the best thing to do is just leave well enough alone.

  • By Howard - edited: January 9

    Update to my previous QoS Post:

    It looks like Netgear has been having issues with QoS, for at least 2 years.   If you search their KB articles, you'll find several articles on resolving QoS issues.

    However, all of them conclude that you'll probably be better off by disabling both the Up-stream AND Downstream options - which are disabled by default.

    It appears that the most reliable way to improve performance is to pay your ISP for faster service.   The same thing goes for slow VPN service.

  • By Howard - edited: February 12

    Yeah,  I had tried multiple variations with everything that was visible.

    But in the end, the only thing that helped was to disable both directions altogether.

    After seventeen years in Wi-Fi, I have seen much that is just incompatible, when mixed with other manufacturers products.

    That's one reason I always recommend Wi-Fi Certified products and features.  Even if they are not the highest performance products, they are the ones most likely to work with another companies certified gear.   There can still be issues, if one piece is tweaking some esoteric  parameter, but overall they will still work.

    Don't get me wrong, there is equipment out there, usually from smaller companies, that may work fine even though they are not certified.   Besides having to pay thousands yearly for a WFA Membership, every certification is an additional cost.   A manufacturer who buys his radio as previously certified device may end up with a compatible device, but without actually being certified.   As long as they don't claim it is Certified, they will probably be ok.  Although it may not have all the bells and whistles it could otherwise have.

    Just as an aside, one of the original complaints against WFA certs was that they didn't take performance into account.   That has changed a lot, and in fact changes made to their certification testing system(s) added its own (inadvertent ?) performance requirements.   It's hard to test thousands of products a year if they are all running slowly, even when you have multiple test houses performing the work.  So their tests were written to run as fast as possible.

    My employer, whose products ran perfectly fine on their own even when highly stressed performing their natural function, had to upgrade the CPU's and increase memory just to keep up with the new  WFA  test sequence generators.   Prior to those upgrades, they were having trouble even counting the number of bytes sent to them, mush less acting on the incoming bit strings.

    Other companies had the same problem.

  • By Howard - edited: March 24

    Just an addendum to my original post.

    Whereas my Netgear  AC router came with QoS disabled  (and I messed it up by enabling it), the Netgear Orbi (Mesh) routers come with QoS enabled - on the AP to Client link.     There are no documented controls for setting QoS parameters on the Orbi's WAN side.

    What this means, is that if your client device(s) have WMM-QoS enabled, you should get the best performance from them.   But, if you really wish to disable it, you can.

    I am impressed by the user manual that comes with the Orbi.  The UI has many controls built in that can be adjusted, although it should work fine as-is.   It is also an FCC class B device which means it should be producing less RFI. 

    Eero (Amazon) documentation is big on marketing speak with lots of pretty pictures.   I prefer the more straightforward, and complete, Orbi documents.

    ---------------------------------------------------------------------------------------------------------------

    PS:   I just checked, and my previous employer still has NO WFA Certified 802.11ac printers, even though I know they worked as printers at /ac rates over 4 years ago.   Obviously they never could get the new O/S design to run fast enough to pass the WFA tests - no matter how much money, memory or CPU horsepower they threw at it.   The problem was not the hardware, it was the overpaid prima donna A-holes, and the fools in management who fell for their BS. 

Page 1 of 1
  • 1